Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 18, 2025 - 09:30 EDT
Scheduled
Planned maintenance is scheduled from Sat, 18 Oct 2025 09:30:00 EDT until Sat, 18 Oct 2025 12:30:00 EDT. Nous allons effectuer une maintenance planifiée de Sat, 18 Oct 2025 09:30:00 EDT jusqu'à Oct, 18 Oct 2025 12:30:00 EDT.
Posted Oct 14, 2025 - 16:34 EDT
This scheduled maintenance affected: Search & Book (Flights, Hotels, Cars, Rail), Chat (Mobile Chat, Web Chat), User Management (Profile, Trips, Admin Portal), Authentication (Login), and Email Delivery.